Haiku/Canto Version 9.3 or Later Now Required

Haiku/Canto version 9.3 or later is now required to continue using these apps. HM-issued devices should be updated automatically.

If you do not have version 9.3 or later:

  • You will see a pop-up notification when logging into Haiku/Canto.
  • Click here for installation instructions.
  • Note: Your user settings and preferences will not be lost.

© 2020. Houston Methodist, Houston, TX. All rights reserved.